History | Log In     View a printable version of the current page. Get help!  
Issue Details (XML | Word)

Key: HJMS-51
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Colin Crist
Reporter: Raju Gottumukkala
Votes: 3
Watchers: 4
Operations

If you were logged in you would be able to see more operations.
HermesJMS

java.lang.NuSuchFieldError: TRACE while trying to browse the JNDI Context

Created: 05/Oct/07 08:59 AM   Updated: 24/Oct/07 05:48 PM
Component/s: None
Affects Version/s: 1.12
Fix Version/s: 1.13

Environment:
JBOSS 4.2.1 GA, JDK 1.5, JDK 1.6, Hermes 1.13, 1.12, 1.10
Windows XP Professional


 Description  « Hide
Getting the above said exception while trying to Browse any of the ConnectuionFactories from JNDI Context.
JNDI Context is able to talk to JBOSS and populated all the available ConnectionFactories
But all these factories are RED in color and are not getting opened, and the error is while trying to open any of these Connection Factories.

I tried it with Hermes 1.12 Mainly and later tried with 1.13 and 1.10 as well by keeping JBOSS environment constantly at 4.2.1 GA
Tried with JDK 1.5 and 1.6

Couldn't see any significant error message at log file except "2007-10-05 08:46:21,671 [main] ERROR hermes.impl.ConfigDAOImpl - cannot find C:\JavaApps\HermesJMS\lib.weaved/hermes-jeus.jar for hermes.ext.jeus.JeusMQAdminFactory"

 All   Comments   Change History      Sort Order:
Colin Crist [23/Oct/07 08:46 AM]
Hermes was using an older and incompatible log4j version that needed upgrading.

Colin Crist [23/Oct/07 09:14 AM]
There is a build that should fix this at http://hermesjms.com/patches

Raju Gottumukkala [24/Oct/07 05:48 PM]
Thank you this fix is working fine.