History | Log In     View a printable version of the current page. Get help!  
Issue Details (XML | Word)

Key: HJMS-186
Type: Improvement Improvement
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Colin Crist
Reporter: Noel Byrne
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
HermesJMS

jar missing from JBoss jboss-eap-5.1 - jboss-as

Created: 02/Feb/12 07:18 AM   Updated: 06/Jul/12 05:48 AM
Component/s: None
Affects Version/s: 1.14
Fix Version/s: 1.15

Environment: jboss-eap-5.1\jboss-as


 Description  « Hide
Hi,
Hermes is excellent, but in my environment, I seem to have a problem.

While following the JBoss installation demo, which is for JBoss 4.0.1, the jbossmq-client.jar jar was missing from the JBOSS installation.

I'm trying to use HermesJMS for maintenance of my queues, and it connects nicely and displays my messages etc. But when I try to move (drag n drop) a message from my DLQ to another queue, I get the following error:
 - 'Unsupported message type ObjectMessage'

My messages are all of type ObjectMessage , so does this mean I cannot use HermesJMS to manage my queues ?

I've just downloaded 1.14 this morning.

Thanks
Noel Byrne



 All   Comments   Change History      Sort Order:
Colin Crist [02/Feb/12 07:44 AM]
Is there a stack trace? Look at hermes.log (the help->about box tells you where it is). Thanks

Noel Byrne [02/Feb/12 08:48 AM]
Hi
thanks for response!

The logfile is complete from a fresh install this morning. There is probably some noise in it, as I tried every message type to see if any worked.

I believe the missing jbossmq-client.jar in JBoss shows up as the error: java.lang.NoClassDefFoundError: org/jboss/mq/SpyConnectionFactory

But my focus is to be able to easily move messages from one queue to another, when the messages are of type ObjectMessage.

Thanks again
Noel

Colin Crist [02/Feb/12 09:13 AM]
Dowloaded and removed...

Colin Crist [02/Feb/12 09:36 AM]

Colin Crist [02/Feb/12 10:54 AM]
You will have issues with ObjectMessages with 1.14.

I shall upload the latest 1.15 beta that does work ok when copying them with the new dialogs. Check it out tomorrow at http://hermesjms.com/patches